If you receive an email indicating that a payment has failed or a payment reminder, this is usually related to your payment method saved in your InputKit account.
Possible causes
Your credit card has expired.
The available balance on your card is insufficient.
There was a temporary issue with the payment processor.
How to fix the issue
Click on your name in the top right corner.
Select Billing.
Click on Change credit card to update your payment method.
Save the new card so that future payments are processed automatically.
You can also check the status of your invoices in this same menu:
Paid – The payment was successfully processed.
Unpaid – Action is required to resolve the issue.
Once your payment method is updated, InputKit will automatically retry the pending payments.
If you have any questions, feel free to reach out to us via chat.